L3 Frozen

JGJG
edited October 2016 in Laisimo FAQ
I tried doing an update on my L3. Downloaded the software, it installed OK on my PC so I removed the batteries, pressed and held the power button for a few seconds then connected it to the PC but nothing, device doesn't even turn on properly now. I have removed the batteries, put them back in normally without holding the power button, device shows the Laisimo logo on the white background when booting then screen goes dark and I can't get it to stay on - removing batteries and trying to boot normally doesn't work. Device is currently not useable, nothing I do seems to make it work.

Help!

Comments

  • JGJG
    edited October 2016
    Got it back to "normal" - Fixed it by continuously pressing the power button on and off while it was booting in the white screen where it locks and goes dark as above, back to normal now.

    Upgrade simply doesn't work for me. Putting the batteries in while holding down the power button never turns the screen on, the screen just remains dark and never boots then locks up and won't boot properly. I have tried this several times now and am having to do the reset on freeze thing by pushing the power button lots during the initial white Laisimo load screen before it crashes and screen goes dark and device is totally unusable.

    Not trying it again until I have more info, hopefully from here, because I can't afford for my power button pressing trick not to work and my device to become permanently broken.

    Device is not upgradeable for me :(
Sign In or Register to comment.